Chia sẻ internet trên router Cisco bằng NAT overload trên GNS3 và VMware

Bài lab này giúp bạn có thể kết nối các máy tính trong một mạng ảo thông qua con router được giả lập trên GNS3. Bài LAB này sữ dụng kỹ thuật NAT overload, một kỹ thuật mà được sữ dụng rộng rãi trên các modem (Router ADSL).

Interface ngoài f0/0 Router kết nối với VMnet 8 (VMnet này chia sẽ internet bằng cách NAT) hoặc bạn có thể kết nối với VMnet0 (chế độ ở VMnet này là Bridged), ở đây tôi khuyến cáo bạn nên dùng VMnet8 để dể kiểm soát. Interface trong Router f0/1 kết nối với VMnet 1. Máy tính kết nổi với VMnet1

Các kỹ thuật được dùng trong bài LAB này cũng rất đơn giản:

Đặt IP trên các interface: interface f0/0 cho nhận DHCP từ VMnet 8, interface f0/1 IP là 192.168.100.254.

Gán NAT inside (interface trong) và NAT outside (interface ngoài) cho lần lược interface f0/1 và f0/0

Trong bài LAB còn dùng các lệnh để chỉ DNS server [ip name-server {dia chi ip DNS server}] và lệnh cho phép router có thể hiểu tên miền [ip doamain-lookup].

Để NAT overload thì ta cần tạo 1 Access-list của lớp mạng bên trong gán vào interface bên ngoài.

Chi tiết về cấu hình, các bạn có thể xem trong video hướng dẩn. Chúc các bạn thành công!

Code tham khảo:

Code IP động interface ngoài

config terminal
interface f0/0
ip address dhcp
ip nat outside
no shutdown
exit
interface f0/1
ip address 192.168.100.250 255.255.255.0
ip nat inside
no shutdown
exit
access-list 1 permit 192.168.100.0 0.0.0.255
ip nat inside source list 1 interface FastEthernet0/0 overload
ip name-server 8.8.8.8
ip domain-lookup
exit

code IP tỉnh interface ngoài

config terminal
interface f0/0
ip address 192.168.174.250 255.255.255.0
ip nat outside
no shutdown
exit
interface f0/1
ip address 192.168.100.250 255.255.255.0
ip nat inside
no shutdown
exit
access-list 1 permit 192.168.100.0 0.0.0.255
ip nat inside source list 1 interface FastEthernet0/0 overload
ip name-server 8.8.8.8
ip default-gateway 192.168.174.2
ip domain-lookup
ip route 0.0.0.0 0.0.0.0 192.168.174.2
exit 

Chia sẻ nào!

Related posts