Giả lập hai hay nhiều đường truyền, site như trên mỗi trường internet

Trên thực tế, chúng ta sẽ cần đến các mô hình nhiều đường truyền hoặc nhiều site để cấu hình các dạng dịch vụ như load balancing và failover, VPN, OpenVPN… hoặc thực hành các lab publish các dịch vụ như web, ftp… Trong bài trước các, chúng ta đã tiến hành chia sẽ internet cho mạng LAN bằng kỹ thuật NAT overload, một kỹ thuật được dùng rộng rãi trên môi trường IPv4, trong bài này chúng ta sẽ kết hợp kỹ thuật này với một số dịch vụ khác.

Như chúng ta đã biết, trong môi trường mạng IPv4 người ta phát triển một dịch vụ NAT, dịch vụ này dùng để tiết kiệm các địa chỉ IP bởi vì IPv4 có số lượng giới hạn và chúng không thể đáp ứng nhu cầu của từng node mạng trên toàn thế giới. Cơ chế NAT overload cho phép máy tính trong mạng LAN với nhiều IP private sử dụng duy nhất một IP Public để kết nối Internet. Các máy trong LAN khi có nhu cầu đi internet sẽ qua modem, modem sẽ dùng IP Public truy cập và trả thông tin về cho máy tính trong LAN. Cơ chế NAT overload không cho phép các máy tính ngoài internet có thể thấy được máy tính trong mạng LAN.

 

Môi trường intenet là môi trường phức tạp với nhiều router, sữ dụng nhiều giao thức định tuyến, nhiều hệ thống cung cấp dịch vụ. Nhưng để đơn giản hóa, chúng ta tưởng tượng  môi trường internet là một cái switch lớn, trên đó các modem đầu cuối phía người dùng của chúng ta sẽ được kết nối vào switch này.

Để thực hiện giả lập, bạn cần thực hiện mô hình sau:

Bạn cũng cần tắt tính năng DHCP có sẵn trên VMnet1 và VMnet2. Biết được lớp mạng của VMnet8 và chúng ta xem lớp mạng VMnet8 bây giờ là Public IP.

Các lệnh được dùng

  • config terminal
  • interface f0/0
  • ip address [Địa chỉ IP thuộc lớp mạng VMnet8] [Subnet Mask]
  • ip nat outside
  • no shutdown
  • exit
  • interface f0/1
  • ip address [Địa chỉ IP cho mạng LAN] [Subnet Mask]
  • ip nat inside
  • no shutdown
  • exit
  • access-list 1 permit [Địa chỉ lớp mạng của mạng LAN] [Wildcard mask]
  • ip nat inside source list 1 interface FastEthernet0/0 overload
  • ip name-server [Địa chỉ DNS server]
  • ip default-gateway [Gateway VMnet8]
  • ip domain-lookup
  • ip route 0.0.0.0 0.0.0.0 [Gateway VMnet8]
  • end

Cấp DHCP từ router cho mạng LAN: Chúng ta có thể cấp IP cho mạng LAN từ router để không phải cấu hình bằng tay cho các client.

  • config terminal
  • ip dhcp pool [Tên pool]
  • network [Địa chỉ lớp mạng của mạng LAN] [Subnet Mask]
  • default-router [địa chỉ IP của Internal interface]
  • dns-server [Địa chỉ DNS server]
  • lease 14 12 23 (Chú giải: đây là thời gian mà client được thuê địa chỉ IP, ở đây là 14 ngày, 12 giờ, 23 phút)
  • exit
  • ip dhcp excluded-address [địa chỉ đầu] [địa chỉ cuối] (chú giải: đây là dạy IP không cấp cho client)
  • end

Bạn có thể tải code mẫu về sau đó sửa lại cho phù hợp theo mô hình của mình. Sau khi thực hiện xong code này bạn đứng từ LAN này truy cập qua LAN kia là không thể, nhưng bạn có thể truy cập intenet bình thường, cụ thể là bạn có thể test bằng lệnh ping để kiểm tra.

Video hướng dẩn tạo hai đường truyền cho hai site và hai line cho load balancing trên pfSense. Để giả lập môi trường mạng này bạn cần cài đặt GNS3 trên Windows hoặc Linux.

Để có thể NAT inside hay còn gọi là publish dịch vụ cho máy tính LAN 2 có thể truy cập vào dịch vụ được triển khai từ LAN 1 bạn thực hiện câu lệnh sau:

ip nat inside source static tcp [IP server] [port dịch vụ] [IP mặt ngoài của router] [port dịch vụ] extendable

Ví dụ mở port web:

ip nat inside source static tcp 192.168.100.251 80 192.168.174.250 80 extendable

Chia sẻ nào!

Related posts